New “report” feature to request a tenant statistic report
The report is an Excel spreadheed with tenant usage information (emails and storage), per-user usage information (emails and storage), charts of usage over time (emails and storage)
New native Zimbra connector
Uses the native Zibra APIs to sync email, folders and for message restore
Office 365 user delegation using custom schema extensions
A user can now be delegated to manage other mailboxes.
Recipient-based SMTP listener authentication
The attribution to the tenant can be based on the recipient of the journal email. For example: journals delivered to tenant1@archiver.mydomain.com are attributed to tenant1, journals delivered to tenant2@archiver.mydomain.com to tenant 2
Features
Delay update until all running jobs are completed
Automatic nightly system updates are postponed until all running import/export jobs are completed
Automatically suspend services when engine disk usage is higher than 90%
In order to avoid data corruption, the archiver will stop ingesting more email if the disk is getting full. The administrator is notified in advance.
Handle IMAP corrupted messages
Better support of less-than-perfect IMAP implementations
Compress folder structure dump while preparing it
The backup of the folder structure requires much less disk space and reduces disk I/O
Support mailbox-based licensing
Introduces a new license based on the number of mailboxes rather than on the storage size
Compress logs to reduce engine disk usage
System logs are now stored in a compressed format reducing disk usage
Add support for zip-based reindex
The granularity of the reindexing process is now higher
Add tenant soft and hard deletion
Tenant deletion is performed through a quick soft-delete followed by a background process of hard-delete
Add customer address list in tenant summary page
Besides showing the number of messages, addresses, listeners and connectors related to the tenant, now the tenant summary page can also list the addresses
Add notification snooze settings
Notifications can be snoozed with a very high level of granularity
Add support for additional data disks
The console menu allows to add disks to the Archiver VM
Improve job error notifications and logging
More information available to the admin about job execution
IMAP journaling skips duplicated, already imported, messages
After having verified that the message is actually already present in the archiver, the duplicate message is skipped
Send notification on automatic index check failures
Index health checks are automatically performed and issues notified to the admin
Keep historical, per tenant, disks usage and emails count statistics
Besides appliance-wide historical usage data, also per-tenant historical usage data is calculated and stored
More logging for outlook-addin authentication failures and email parsing failures
Debugging these kind of issues is now faster thanks to more details provided to the admin
Synchronization for a single connector can be launched
The admin can force a synchronization execution for a single connector, without waiting for the nightly sync
Add message IDs dump to backup procedure to speed up the restore (and reindex) process
With this additional information in the backup, the restore is much faster
Re-design SMTP listener configuration page
UI redesign for a better user experience
Delegation support in outlook-addin
Delegated users can manage other mailboxes also from within the outoook-addin
Bugfix
Fix user impersonation if user has a domain not configured under tenant domains
Fix OTP token regeneration in tenant page
Regenerate kerberos configuration after archiver update
Use correct Content-Type header when downloading messages as msg, eml or pdf
Remove : from folder struct dump file to prevent failures on SAMBA volumes
Fix PST importer skipping folders starting with .
Fix HTML email indexing not correctly handling invalid HTML emails
Fix tenant selector keeping old selection even if it’s no more valid
Improvements
archiver update: stop if export jobs are running
stop services if /var usage is higher thank 90%
improve IMAP connector memory managements
skip IMAP corrupted messages
limit maximum log lines shown in webinterface
add appliance level OTP code
improve folder structure creation
improve user impersonation if user domain is not in tenant domains
improve fix otp token regeneration
improve SMB share volumes
improve disk usage and indexes email stats collection